This incident has been resolved. If you are still experiencing an issue, please open a support request. Thank you!
Posted Jun 04, 2026 - 18:00 EDT
Update
Good Morning,
Our Team continues to track down the source of the delay, which, in some cases causes the mobile app to not display the inbound ringing event. With that said, they have found that this is affecting very few devices in comparison to the total amount of customers using the mobile app. With the issue affecting so minimal users, if you are experiencing this issue, please open a request with us, by emailing support@lucidcommunications.net.
We appreciate your patience while our team continues to work on this issue.
Posted Jun 04, 2026 - 10:18 EDT
Investigating
We're aware of an issue with ConnectUC Mobile clients are having their Push Notifications become invalid.
What are the symptoms - Push Notifications are used when the app is in the background (phone has the screen off, or some other app is in the foreground). They alert a user of a new call/sms/chat/fax. This can cause a mobile client to not ring or have any of the other features check and notify of new items.
Temporary Workaround - Uninstalling the ConnectUC Client and then re-installing from the App Store will create new push notification tokens and all push notifications will then function properly.
Engineering is currently investigating and working on a fix.